CentOS based Podman build

Hello all:
Good morning and afternoon. This is my first time here so apologies if this is the wrong forum. Please direct if there is a better place for these questions.

I found Fiduswriter while doing a search for a Lyx replacement for some internal documentation that I need to create. On installation, I had some issues with an Ubuntu based build (mainly with libjpeg dependencies and a module find_namespace_packages) so switched over to CentOS as the base.

I’ve placed this build here: https://github.com/kwanlowe/digitalhermit_website/tree/master/linux/fiduswriter

The build succeeds, but there are some warnings regarding typescript during the setup process:

npm WARN tsutils@3.21.0 requires a peer of typescript@>=2.8.0 || >= 3.2.0-dev || >= 3.3.0-dev || >= 3.4.0-dev || >= 3.5.0-dev || >= 3.6.0-dev || >= 3.6.0-beta || >= 3.7.0-dev || >= 3.7.0-beta but none is installed. You must install peer dependencies yourself.

In my Dockerfile (https://github.com/kwanlowe/digitalhermit_website/blob/master/linux/fiduswriter/Dockerfile) I am explicitly pulling down this version. It does seem to work when I attach directly to the container and install and does not abort the build, but I’m not sure if this is a fatal error.

Can I safely ignore these? How is this typescript package used?

Anyway, thanks for a great tool. I’m using it internally for documentation and the results look wonderful.

Best regards,

Hey @DigitalHermit,
did you have problems with the Ubuntu Snap or some other way of installing it on Ubuntu.
We don’t use TypeScript directly in Fidus Writer. It is used in some dependencies, but those should be cross compiled. So I don’t think you really need it.


Thank you @johanneswilm:
Unfortunately I don’t have any Ubuntu servers in the environment, just on a couple laptops. When I tried on a CentOS server, I ran into a Django invalid header error. I’ll need to revisit the docs as it seems my ALLOWED_HOSTS entry in the configuration.py is not being picked up.

Thanks again and best regards,

I hope you get it working. Note that it is not just a standard django app - the manage.py file has been rewritten and it’s using Tornado.
Can you not install the Snap on Cent OS?