Problem inserting an image with a local instance of Fidus writer

Although this function works fine in, with the same browser, when I use a local instance of Fidus Writer on my own machine (installed via Snap, using Ubuntu) it does not seem to be able to ‘upload’ the image necessary to insert into a document. It comes up with two errors - ‘Internal Server Error’ and ‘Some Errors were found. Please examine the form.’ I’ve attached a screen grab.

Hey @J.J_Meggitt ,
that looks strange. I tried uploading an image locally myself and it wouldn’t work the first time, but that was because I logged in very quickly and it hadn’t yet had time to update the application in the browser. When I tried again 25 seconds later, it did work.

The server on is also running the Snap, so there should be no difference there.

If the problem persists, perhaps you could give me some information about the image or your computer that could be relevant? The version of Ubuntu you are running would be of interest.

Yes. Problem still there. I am using Ubuntu 22.04 LTS. Here is the rest of my computer info. Using Google Chrome.

Spoke too soon. I changed the name of the image to something much shorter and it worked. I doublechecked by trying the old image name - and that still doesn’t. Oddly the original name did work on fiduswriter,com
Anyway, the main thing is, the problem is now solved.

Interesting! where there any special characters * in the name?

*) accent signs, emojis, m-dash, Mongolian Vowel Separator, etc. .

This is what it was:

(Edited) Riot in the Amphitheatre, fresco, first century C E, from Pompeii.png